
1. Introduction

This tutorial is based on Vivado HLx 2018.2 WebPACK ( free at xilinx . com). The cir cuit used 
in the tutorial is the registered unsigned adder of figure A.1a, synthesized with the VHDL 
code of figure A.1b. The adder inputs (a, b) are 3- bit signals, while its output (sum) is a 4- bit 
signal, so overflow never occurs. Both functional and timing simulations are shown using 
the stimuli of figure A.1c and in the following two situations: using a testbench (figure A.1d) 
and using a Tcl script (figure A.1e).

The structure of the work library created by Vivado is shown in figure A.2. The registered_
adder.srcs folder contains all source files (files created by the user), divided into three catego-
ries: sources_1 (design files), sim_1 (simulation files), and constrs_1 (constraint files). Note the 
file called registered_adder.xpr, which is the Xilinx proj ect file; clicking on it opens the proj ect.

2. Starting a New Proj ect

a) Launch Vivado, which opens the screen of figure A.3a.

b) Click Create Proj ect and Next, which leads to figure A.3b. Enter the proj ect name 
 (registered_adder) and the desired location for the proj ect. Mark Create proj ect subdirectory 
and click Next.

c) In figure A.3c, mark RTL Proj ect (VHDL, in our case) and Do not specify sources at this 
time, then click Next.

d) In figure A.3d, select the FPGA device or the FPGA board. In this tutorial, the 
XC7A35TCPG236 Artix-7 FPGA is employed. Click Next and Finish, which fi nally opens the 
proj ect Flow Navigator (figure A.4).
Note: The FPGA se lection can be made or changed  later at PROJ ECT MAN AG ER > Settings.

e) Observe on the lefthand side of figure A.4 the several sections of the Flow Naviga-
tor: PROJ ECT MAN AG ER, IP INTEGRATOR, SIMULATION, RTL ANALY SIS, SYNTHESIS, 
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Figure A.1
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IMPLEMENTATION, and PROGRAM AND DEBUG (compare to the design flow described in 
chapter 5).

3. Entering (and Testing) the Design File

 Here, we must enter our VHDL design file (registered_adder.vhd, figure A.1b) The compiler  will 
check the syntax and compile the code at register transfer level (RTL) level (no synthesis or 
placement yet), subsequently showing the corresponding elaborated design (i.e., the cir cuit, 
as understood from the VHDL code). The resulting schematic is equivalent to RTL View in 
Quartus Prime.

a)  Under PROJ ECT MAN AG ER, click Add Sources, which opens the win dow of figure A.5a. 
Mark Add or create design sources and click Next.

b) In the next screen, click Create File (or click Add Files if the file is already available).

c) In figure A.5b, select VHDL and enter the file name (registered_adder), then click OK.

d) In figure A.5c, enter the entity name (registered_adder) and the architecture name (rtl). 
Click OK and then Finish.

e) In figure A.5d, note that registered_adder …  is included in the Design Sources list and 
in the Simulation Sources list. Double click the former, which opens the editor (figure A.5f). 
Type the VHDL file (registered_adder.vhd, figure A.1b) and save it by clicking .

f) In figure A.5e, open the General tab and select Type: VHDL 2008.

g) A very impor tant feature of Vivado is that errors in the code of nonsupported VHDL con-
structs are underlined in red. Introduce an intentional error in the code to observe that.

h) RTL Analy sis: We can now check how our code was understood by Vivado.  Under RTL 
ANALY SIS, click Open Elaborated Design; when done, click Schematic. The resulting RTL 
view is shown in figure A.6, which matches the cir cuit of figure A.1a.

Figure A.2
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4.  Doing Behavioral Simulation with Testbench

Notes:

1) Recall that functional simulation, still at the RTL stage, is called behavioral simulation. 
 After Synthesis or  after Synthesis plus Implementation, its equivalent is called functional sim-
ulation. Timing simulation only exists for the latter two cases.

2) In  simple designs, one might opt for skipping behavioral and even functional simulation. 
Timing simulation is always indispensable.

3) The simulation described  here uses a VHDL testbench (see chapter 18; the testbench file 
is that of figure A.1d). Another option, described in the next section, is to use a Tcl script.

a) The first step is to enter the VHDL testbench file.  Under PROJ ECT MAN AG ER, click Add 
Sources, which opens the win dow of figure A.5a. This time, mark Add or create simulation 
sources and click Next.

b) In the next screen, click Create File (or click Add Files if the file is already available).

Figure A.4



Figure A.5



Vivado Tutorial 503

c) In figure A.5b, select VHDL and enter the file name (registered_adder_tb.vhd), then click OK.

d) In figure A.5c, enter the entity name (registered_adder_tb, figure A.1b) and the architecture 
name (testbench). Click OK and then Finish.

e) In figure A.5d, note in the Sources pane that registered_adder_tb -  … is added to the Sim-
ulation Sources list. Double click it, which opens the editor (figure A.5f). Type the testbench 
file (registered_adder_tb.vhd, figure A.1d) and save it by clicking .

f) In figure A.5e, open the General tab and select Type: VHDL 2008.

g) We can now run the simulation.  Under SIMULATION, select Run Simulation > Run 
Behavioral Simulation, which leads to figure A.7a. Move clk to the top if not  there yet.
Note: To break a simulation, select Run > Break.

h) Make the following adjustments:

-  Change the time to 320 ns at .

-  Click the Restart icon .

-  Click the Run for time T icon .

-  Click the Zoom Fit icon .

-  Select all signals except clk of figure A.7a, click the right mouse button, and change the 
radix to Radix > Unsigned Decimal.

The final result is shown in figure A.7b.

i) Fi nally, inspect the simulation results of figure A.7b and confirm that they comply with 
figure A.1c.

j) Click  and then  for the simulation to advance another 320 ns.

k) To end a simulation, close the wave pane or type close_sim – force in the Tcl console.

Figure A.6
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5.  Doing Behavioral Simulation with Tcl Script

This section shows how to run a simulation using tool command language (Tcl, pronounced 
“tickle”) scripts.

Note: If you prefer, you can remove the testbench file from the proj ect by right- clicking on 
the file name and selecting Remove File from Proj ect.

a) Review the Notes at the beginning of part 4 of this appendix.

b) The first step is to prepare the Tcl script (check appendix A1, Some Impor tant Tcl Commands 
for Vivado, at the end of this tutorial). The script of figure A.1e  will be used  here. Assuming 
again that the clock period in figure A.1c is 80 ns, the total  running time is 320 ns.

c) You can type the script in the Tcl console (Win dow > Tcl Console) one line at a time, or 
you can save it in a text file and run it all at once. For the former, proceed in (d); for the latter, 
jump to (g).

d)  Under SIMULATION, select Run Simulation > Run Behavioral Simulation. This opens 
the waveforms pane of figure A.7a. Move clk to the top if not  there yet.

e) Enter the Tcl commands.  After entering run 320 (and clicking , if necessary), the screen 
of figure A.7b  will be displayed.

f) Now that the simulation is done, play with the simulator by  doing parts (h)–(k) of this 
appendix’s part 4.

g) The Tcl script of figure A.1e can be typed in a text editor and saved (call it registered_adder.
tcl) in the same folder the testbench file was saved before (i.e., registered_adder.srcs/sim_1/new). 
Another option is to use Vivado’s editor as follows.

Figure A.7
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h)  Under PROJ ECT MAN AG ER, click Add Sources, which leads to figure A.5a. Mark Add or 
create simulation sources and click Next.

i) In the next screen, click Create File.

j) In figure A.5b, select Memory File and enter the file name (registered_adder.tcl), then click 
OK.

k) Note in figure A.5d that this new file name appears  under Memory File in the Simulation 
Sources list. Click on it; this opens the editor. Type the script, and save the file. Fi nally, in 
figure A.5e, change Memory File to TCL.

l) Run the Tcl file by selecting Tools > Run Tcl Script and pointing to the Tcl file. The result 
is that of figure A.7b.

m) Now that the simulation is done, play with the simulator by  doing parts (h)–(k) of part 4 
of this appendix.

6. Synthesizing the Design

a)  Under SYNTHESIS, click Run Synthesis.

b) When finished, the win dow of figure A.8a opens. Cancel Implementation for now.

Figure A.8
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c)  Under SYNTHESIS, click on Open Synthesized Design, then open Schematic, which 
shows the cir cuit  after synthesis (figure A.8b), which is the cir cuit that  will actually be fitted 
and routed in the final (Implementation) phase.

d) Select Win dow > Design Runs or open the Design Runs tab in the lower part of the main 
win dow to see the resources usage. As shown in figure A.8c, three lookup  tables (LUTs) and 
four flip- flops  were employed to build this cir cuit.

7. Implementing the Design

a)  Under IMPLEMENTATION, click Run Implementation.

b) When finished, observe that information similar to that in figures A.8b and A.8c is given 
 here.

c) Observe also in the Proj ect Summary win dow (click  if it is not open) that now Synthe-
sis Status = Complete and Implementation Status = Complete. The resources usage is also 
summarized at the bottom of the screen.

8.  Doing Functional Simulation with Testbench

Follow this appendix’s part 4, except for part 4(g), in which you must select one of the 
following:

Simulation > Run Simulation > Run Post- Synthesis Functional Simulation or

Simulation > Run Simulation > Run Post- Implementation Functional Simulation.

9.  Doing Functional Simulation with Tcl Script

Follow part 5, except for part 5(d), in which you must select one of the following:

Simulation > Run Simulation > Run Post- Synthesis Functional Simulation or

Simulation > Run Simulation > Run Post- Implementation Functional Simulation.

10.  Doing Timing Simulation with Testbench

Follow part 4, except for part 4(g), in which you must select one of the following:

Simulation > Run Simulation > Run Post- Synthesis Timing Simulation or

Simulation > Run Simulation > Run Post- Implementation Timing Simulation.

Timing simulation results are shown in figure A.9a. In figure A.9b, a zoomed-in view is 
shown, so propagation delays can be clearly observed.
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11. Assigning Pins

a) Select Flow > Open Implemented Design.

b) Select Win dow > I/O Ports or click the I/O Ports tab at the bottom of the screen, which 
leads to figure A.10.

c) In the Package Pin column, enter the names of the pins to which the cir cuit ports should 
be routed. Mark them as Fixed.

d) Update the design by selecting Implementation > Run Implementation (this  will include 
resynthesis).

12. Programming the FPGA

a) Select Flow > Open Implemented Design.

b)  Under PROGRAM AND DEBUG, select Generate Bit Stream.

c)  Under PROGRAM AND DEBUG, select Open Hardware Man ag er to program the 
FPGA.

d) Fi nally, play with the FPGA board to verify  whether the implementation works as 
expected.

Figure A.9
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Appendix A1. Some Impor tant Tcl Commands for Vivado

• Command add_wave: Adds waveforms to the wave pane.

Examples:

add_wave clk Adds wave clk to the wave pane.

add_wave clk - after_wave rst Adds wave clk to the wave pane  after the rst wave.

add_wave clk inp outp Adds waves clk, inp, and outp to the wave pane.

add_wave / Adds all ports in the design to the wave pane.

add_wave sum – radix dec Adds wave sum to pane with dec radix.

Note: Allowed radix values are bin (default), unsigned, dec (signed decimal), hex, oct, ascii.

• Command add_force: Defines the shape and radix of the waveforms.

Examples:

add_force clk {1 0} {0 40} – repeat_every 80 – cancel_after 2000

Wave clk has value = 1 at time = 0, then 0 at 40 ns, repeats  after 80 ns, resulting T = 80 ns, 
and stops  after 2 μs.

add_force clk {1} {0 40} – repeat_every 80 – cancel_after 2000

Same as above (time = 0 does not need to be specified).

add_force inp1 {2} {5 40} – radix unsigned

Wave inp1 is 2 at time = 0, then 5 for time = 40 ns and higher, with unsigned radix (see 
radix options above).

add_force inp2 {–3} {3 40} {–8 250} – radix dec

Figure A.10
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Wave inp2 is –3 at time = 0, 3 at 40 ns, then –8 at 250 ns, signed decimal radix.

• Command launch_simulation: Opens a simulation.

• Command run: Runs a simulation.

Examples:

run 700 ns Runs simulation for 700 ns.

run 700 Same as above (default time unit is ns).

• Command close_sim – force. Ends simulation without saving waveforms.

• Command restart: Restarts a simulation.

• Command current_time: Gets the current time in the simulation.

• Command open_project: Opens a proj ect.

Example: open_project c:/xilinx/my_designs/registered_adder.xpr

• Command open_report: Displays or copies to an output file the contents of an RPX file.

Examples:

open_report – file results1 design1.rpx Copies the contents of design1.rpx to file results1.

open_report design1.rpx Shows the contents of design1.rpx in the Tcl console.

Tcl script example: See figure A.1e, which contains the stimuli of figure A.1c.


